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Notices 

 The reproduction, transmission or use of this document or its contents is not permitted without express 

written authority.  

 Information and specifications in this document are subject to change without notice. 

 While information in this document is well edited and checked, mistake or omission may exist. Please 

don’t hesitate to contact SUPCON if you have any question about this document.  

 Please contact SUPCON via email "SMS@supcon.com" if you have any question. 

 

 

Trademarks 

Trademarks or marks SUPCON, SPlant, Webfield, ESP-iSYS, MultiF, InScan, SupField are all registered, 

registering or using by Zhejiang SUPCON Technology Co., Ltd., which owns the properties of all trademarks or 

marks above. Without the written authority from Zhejiang SUPCON Technology Co., Ltd, no individual or 

company shall use any trademarks or marks above. We reserve the right to take legal action for any individual or 

company using trademarks or marks above illegally. 

 

 

Symbol Definition 

 

WARNING: Indicates information that a potentially hazardous situation which, if not avoided, could 

result in serious injury or death. 

 

RISK OF ELECTRICAL SHOCK: Indicates information that Potential shock hazard where 

HAZARDOUS LIVE voltages greater than 30V RMS, 42.4V peak, or 60V DC may be accessible. 

 

ESD HAZARD: Indicates information that Danger of an electro-static discharge to which 

equipment may be sensitive. Observe precautions for handling electrostatic sensitive devices 

 
ATTENTION: Identifies information that requires special consideration. 

 
TIP: Identifies advice or hints for the user. 

xmpp:SMS@supcon.com�
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WLCon Software User Manual 

Section 1 Overview 

WLCon software allows you to configure the settings of wireless devices. 

SUPCON provides wireless devices including wireless gateway GW042, wireless adaptor ADP01, 

wireless temperature transmitter TM52W0, and more. SUPCON industrial wireless sensing 

solution utilizes wireless devices to realize the data acquisition and wireless transmission of 

wireless temperature and pressure transmitters, as well as common instruments (if used with 

wireless adaptors). The collected data is sent to the control system through Ethernet, or 4G/5G 

network. 

1.1 System Structure Diagram 

The figure below shows a typical network structure of the DCS integrated wireless devices. 
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Figure 1-1 A typical network structure using SUPCON wireless devices 

 

1.2 System Components 

In the above figure, the system consists of: 

 Controller 

The controller connects with the wireless gateway by means of E-Bus network, to receive 

data from the wireless instruments and send commands to the instruments. 

 Wireless Gateway 

The wireless gateway serves as a bridge that connects the control system and field 

wireless instruments. It connects with the controller through E-Bus network and with the 

field devices by means of wireless network. 
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 Wireless Adaptor 

The wireless adaptor measures field current and HART signals, converts these signals 

into wireless signals, and sends them to the wireless gateway. 

 Wireless Instruments 

Wireless instruments adopt standard industrial wireless protocols to collect field signals 

and to send real-time data and diagnostics to the wireless gateway. By receiving 

commands from the gateway, it helps achieve wireless control in the field. 

 

 
Tips: 

 For more information on wireless gateways, refer to GW042 Series User Manual. 

 For more information on wireless adaptors, refer to ADP01-1AI-WSN-S User Manual. 

 For more information on wireless instruments, refer to TM52W0 User Manual. 
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Section 2 Configuration Flow 

To connect wireless devices with DCS, follow the steps shown in the figure below. 

 

Figure 2-1 Typical configuration flow of wireless devices 
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Section 3 Prerequisites 

Install the WLCon software and prepare GSD files before starting configuration. 

3.1 Installing WLCon 

WLCon software is integrated into VFIOBuilder of High-performanceHMI software. You do not 

need to install it separately and it cannot be uninstalled separately. 

Follow the installation guide to install the DCS system software. 

3.2 Preparing GSD Files 

Acquire the GSD files from your supplier. Read carefully the user manuals of corresponding 

devices. 

WLCon software offers GSD files for common devices, which are stored in 

"DPCon\WSNConfig\Profibus\GSD" of software package directory. If you want to import other 

GSD files, refer to Importing GSD File. 

 

 
Tip: 

The provided GSD files are for reference only. 
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Section 4 Adding Master Station Communication 

Module 

Add a master station communication module, such as GW042 WSN, before starting configuration. 

1) Start VFExplorer software. 

Select OMC > VFExplorer from the start menu. 

2) Open control station configuration. 

Open the default project and select a control station. Double-click Hardware 

Configuration. 

3) Add GW042. 

Right-click on the controller, and click Add. The Add Module window will pop up. Select 

GW042 WSN Communication Module and configure its address. Click Add to add it to 

the navigation tree. 

4) Right-click on the GW042 node and click Communication Configuration to open 

WLCon software. 

 

Figure 4-1 Add GW042 and start communication configuration 

 

 

Attention: 

GW042 only can be added in Hardware Configuration and configured in WLCon. You 

cannot add or configure it by importing the hardware configuration. 
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Section 5 Communication Configuration 

This section takes GW042 WSN communication module as the example to describe how to use 

WLCon for wireless device configuration. 

5.1 Starting WLCon 

In Figure 4-1, click Communication Configuration. The main window of WLCon will be 

displayed. 

 

Figure 5-1 WLCon main window 

 

5.2 Configuring the Master Station 

1) Double-click the icon of master station to open Master Configuration window.  
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Figure 5-2 Master configuration 

2) Specify Net ID and JoinKey. 

Net ID and JoinKey of field instruments that are added under the master station must be 

the same as the master station; otherwise, they cannot communicate with each other. 

5.3 Importing GSD File 

WLCon recognizes wireless devices by means of a GSD file. Before adding a wireless device, 

make sure its GSD file is imported. 

1) Select Import GSD command. 

In WLCon software, select File > Import GSD. In the pop-up window, select the GSD file. 

2) Start importing. 

After you select a GSD file, WLCon will start importing the file and recognizing the device.  

3) After import, restart WLCon to make the changes take effect. 

 

 

Tip: 

During import, the software may display a prompt saying the dib file does not exist. If the file 

cannot be included, select Cancel. It will not impact the import process. 

 

5.4 Adding and Configuring Slave Station 

 

Attention: 

The characteristics of the slave stations are different. Please conform to the user manuals of the 

corresponding slave devices when configuring the slave stations. 
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WLCon provides multiple methods to add slave stations. For example, you can select a slave 

station from the vendor list and drag it to the diagram, or right-click the bus and click Insert Slave. 

The following steps show an example of adding TM52W0 as the slave station and illustrate how to 

configure it. 

1) Add Slave Station 

Select the slave station (such as TM52W0) from the vendor list. Click and drag it to the 

bus. The Slave Information window is displayed. Enter "3" in the Address field and 

"Slave3_TM52W0" for Default Tag. Click OK. 

 

Figure 5-3 Slave information window 

2) Add a module to the slave station. 

Double-click the slave station to open Slave Configuration window.  

Some fields are updated from the GSD file, such as the maximum number of modules, 

and module type (4byte+1byte and 4byte). Here byte refers to the status code or unit. 

You can add field modules as needed. The figure below is an example of adding four 

4-byte input modules to the slave station. 
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Figure 5-4 Configure I/O module 

3) Configure sampling data. 

Click Parameter Data. In the pop-up window, configure wireless instruments through 

GSD file. 
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Figure 5-5 GSD parameter data 

4) Configure the corresponding values of the four bytes, as shown in the figure above. 

 

5.5 Saving Configuration 

After finishing communication configuration, click  to save it. Close WLCon software and go 

back to VFIOBuilder.
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Section 6 Tag Configuration 

After finishing wireless device configuration, configure the tags of wireless device in VFTAGBuilder, 

including adding wireless tags and configuring tag properties. 

6.1 Prerequisites 

Before configuring wireless tags, make sure you have: 

1) Updated the configuration. 

In VFIOBuilder, right-click "GW042" and select "Update Configuration". 

2) Saved hardware configurations. 

Select File > Save to save the configurations. 

6.2 Adding Tags through Communication Tag Strategy 

1) Open Communication Tag Strategy window. 

In VFTAGBuilder, select Operation > Scan Tags from Channel > Communication Tag 

Strategy. 

2) Select the slave station the tags belong to. 

Select the slave and its slots from the left navigation tree. Figure 6-1 Takes slave 002 and 

slot 00 as an example. 

3) Configure tag strategy. 

Add strategy: click a slot and select the tag type and status code for it. Click Add 

Strategy.  

Modify a strategy: select a strategy and modify its tag type or status cod. Click Modify 

Strategy. 

Delete a strategy: select a strategy and click Delete Strategy. 

4) After setting up tag strategies, click OK and go back to VFTAGBuilder software. 
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Figure 6-1 Configure communication tag strategy 

 

 

Attention: 

A slot can only have one tag strategy. 

 

5) Add tags. 

After configuring the strategies, you can add tags to your configuration in VFTAGBuilder. 

Select Operation > Scan Tags from Channel. Click Scan New Added to start scanning 

and adding tags. After scanning, the window is shown like Figure 6-2. 
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Figure 6-2 Tag scanning complete 

6.3 Manually Adding/Modifying Tags 

You can manually add or modify tags in VFTAGBuilder. Here takes AI communication tags as an 

example to describe how to manually add wireless communication tags. 

1) Select tag type. 

In VFTAGBuilder, select Analog Input from the drop-down list, and select Operation > 

Add Tag. A new tag is added to the list. 

2) Configure tag properties. 

Select the newly added tag and configure its properties on the right pane. 

6.4 Usage of Different Communication Tags 

 AI/AO tag parameters 

 Input/Output Channel Settings 

Communication Node No.: the node address of GW042 on E-Bus network, which is 

the address set during the hardware configuration. 

Communication Rack No.: specify the communication rack number of the tag. 000 by 

default. 

Slave Station Address: address of the slave station. 

Data Block No.: slot number in hardware configuration 

The Offset Address of the Tag in the Data Block: offset address of the analog tag in 

the data block. Unit: byte 

 Communication Parameter Settings 

Data Type: 5 types are available. 
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Status Code Location: "No Status Code", "Status Code Ahead", "Status Code 

Behind" are available. For slave signals, select No Status Code. 

Data Format: select the conversion type. 

 Input/Output Original Code Settings 

Set the upper and lower limit of the original code. Original code varies with slave 

stations. 

 DI/DO tag parameters 

 Communication Node No.: the node address of GW042 on E-Bus network, which is 

the address set in hardware configuration. 

 Communication Rack No.: specify the communication rack number of the tag. 000 

by default. 

 Slave Station Address: address of the slave station. 

 Data Block No.: slot number in hardware configuration 

 The Offset Address of the Tag in the Data Block: offset address of the digital tag in 

the data block. Unit: bit 
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Section 7 Compiling and Downloading Configuration  

After configuration is finished, close VFIOBuilder and go back to VFExplorer. Save, compile, and 

download the configuration. Online download and offline download are available for downloading 

system configuration. 

 Online download: When there is no major change in configuration and the online device 

is not modified, carry out online download. Online download can ensure that the 

unmodified device, its commands and relation between the commands and the tag 

remain unchanged. 

 Offline download: When there is major change in the configuration, for example, 

modification to the hardware structure of the system and the system forbids the user to 

carry out online download to ensure site safety. When it is ensured that there will be no 

major problem, offline download can be selected. 

 

 

Attention: 

 After configuring the wireless tags, do not switch to another tag when you are editing 

a tag. 

 The method of calling wireless tags in DCS configuration and custom programs is the 

same as calling custom variables. 
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Section 8 Online Diagnosis and Device Management 

WLCon offers online diagnosis and device management functions in debug mode. In WLCon, 

select Online > Debug Mode. The debug interface is similar to the figure below. 

 

Figure 8-1 Device status and authorization status in debug mode 

 

8.1 Device Statuses 

See the following table for descriptions of these icons. 

Table 8-1 Icons and descriptions 

Icon Description 

 
Slave in non-debug mode 

 
Slave communication is normal in debug mode 

 

Slave communication is abnormal (slave offline, instrument mismatch) in 
debug mode 

 
Master in non-debug mode 

 
Master communication is normal in debug mode 

 
Master communication is abnormal (slave offline) in debug mode 

8.2 List of Unauthorized and Authorized Exceptions 

In online mode, the controller periodically scans the wireless gateway and its slave stations. The 

gateway will send the information of authorized and unauthorized devices. The controller 

determines if the device is authorized based on the sent data. 

 For authorized devices, you can view them on the web client of the gateway. For details, 

refer to GW042 Series User Manual. 
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 For unauthorized devices, you can view them on the right pane in WLCon software in 

debug mode. See Figure 8-1. 

8.3 Online Diagnosis 

In debug mode, click the master station icon and select Online > Diagnose. Or, you can right-click 

on the icon and select Diagnose. Diagnose Information window will be displayed. Click Reset to 

update the statistics. 

 

Figure 8-2 Master diagnosis information 

 

8.4 I/O Monitor 

In debug mode, click a slave station and select Online > I/O Monitor. Or, right-click on the icon 

and select I/O Monitor. 
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Figure 8-3 I/O tag real-time value 

 

Click Update, then the real-time input and output data will be displayed. Click Hex to convert the 

decimal values to hexadecimal values. 

8.5 Real-time Diagnosis 

Diagnosis software offers real-time diagnosis function over GW042, ADP01, TM52W0, and other 

wireless modules. Diagnosis items include network overall status, diagnostics of GW042 and its 

slave wireless devices. 

In the real-time monitoring software, select System Status from the drop-down list. Select the 

current control station, the diagnosis information will be displayed. 

 

Figure 8-4 Overall diagnosis result 

 

8.5.1 Diagnosing GW042 

In the diagnosis screen, double-click GW042 to display its details. Diagnosis items include working 
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status, power status, communication status, and more. 

 

Figure 8-5 Example of GW042 diagnostic information 

 

The table lists the meaning of the diagnostic items, possible reasons, and solutions. 

Item Meaning Possible Reasons Solutions 

Device type 

Module type. 
Displays fault if the 
hardware is 
inconsistent with 
the configuration. 

Hardware is inconsistent 
with the configuration. 

Check the hardware and software 
configuration. 

Work status 
Displays working or 
standby. 

— — 

24V Status-A 

Displays power 
voltage status. 
Shows fault if the 
voltage is not within 
the range of 20 V to 
28 V. 

Power fault 
Module hardware fault 

1. Check the power wiring 
2. Check if the power module is faulty
3. Replace the module 

24V Status-B 

Displays power 
voltage status. 
Shows fault if the 
voltage is not within 
the range of 20 V to 
28 V. 

Power fault 
Module hardware fault 

1. Check the power wiring 
2. Check if the power module is faulty
3. Replace the module 

WSN Bus 
communication 
status 

Displays the 
connection status of 
WSN bus. 

Wireless environment 
abnormal 
Module hardware fault 

1. Check if the wireless instrument is 
working normally. If it is normal but 
the status is offline, then the wireless 
network is abnormal. 
2. Check the wireless environment to 
see if there is blockage or 
electromagnetic interference 
between the instrument and GW042.
3. If the fault still persists, the module 
might be faulty. Replace the module.
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Item Meaning Possible Reasons Solutions 

E-Bus Network 
A# 
communication 
status 

Displays fault when 
the E-Bus A 
communication port 
is faulty or not 
connected. 

Module bus A fault 
Controller bus A fault 
Module hardware fault 

1. Check if the E-Bus A indicator on 
the module is normal. If not, check if 
the wiring is normal. 
2. Check E-Bus A is normal, check 
the controller E-Bus A. 
3. Reset 
4. Replace the module 

E-Bus Network 
B# 
communication 
status 

Displays fault when 
the E-Bus B 
communication port 
is faulty or not 
connected. 

Module bus B fault 
Controller bus B fault 
Module hardware fault 

1. Check if the E-Bus B indicator on 
the module is normal. If not, check if 
the wiring is normal. 
2. Check E-Bus B is normal, check 
the controller E-Bus B. 
3. Reset 
4. Replace the module 

Redundant 
status 

Displays if the 
current device is 
redundantly 
configured. 

— — 

Address conflict 
Displays fault when 
there is IP address 
conflict. 

Module with the same 
address exists on the 
network. 

Check the indicators of all nodes on 
the network. If the E-Bus indicator of 
any module is flashing, and the 
E-Bus communication of the two 
channels are all normal, they might 
share the same address. Correct the 
IP address. 

Request 
communication 

Displays the 
communication 
request status of 
this node. 

Hardware fault 
1. Reset the module. 
2. Replace the module 

Config status 
Displays if the 
current device is 
configured 

Hardware fault 
1. Reset the module. 
2. Replace the module 

Start status 

Displays if the 
current device is 
started. If the device 
is started, shows 
started; if it is not 
started or there is 
no communication 
data, shows not 
started. 

Hardware fault 
1. Reset the module. 
2. Replace the module 

 

8.5.2 Diagnosing Other Wireless Devices 

On the overall diagnosis screen, double-click a slave of GW042, then the detailed diagnostic 

information is shown. The diagnostic information of other devices includes fault status and 

connection status. See figure below. 
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Figure 8-6 Example of diagnosing a wireless device 

 

The table below lists the diagnostic items, possible reasons, and solutions. 

Item Meaning Possible Reasons Solutions 

Module 
fault level 

Displays if the module is 
faulty. 

Displays "normal" or "???". 
Check the hardware and software 
configuration. 

Module 
connect 
test 

Shows the wireless 
connection of the module 

WSN bus or the module is 
abnormal. 

1. Check whether the wireless 
instrument is working normally. If the 
instrument is normal but the status 
displays ???, it means the wireless 
network is abnormal. 
2. Check the wireless environment to 
see if there is blockage or 
electromagnetic interference 
between the instrument and GW042.
3. If the fault still persists, the module 
might be faulty. Replace the module.

 



WLCon Software User Manual 

23 

Section 9 Other Functions 

Table 9-1 introduces other menus and commands in WLCon software. 

Table 9-1 Other menus and commands 

Menu Command Description 

Settings Preference View the GSD file path and type. 

Project Property 
Configure the general and communication properties. Communication 
properties are different for different systems. 

Device 
Table 

View the device list on the bus. 

Address 
Table 

View the device address list on the bus. Tools 

GSD 
Explorer 

Select a GSD file to view its information. 

Help 
About 
WLCon 

View the software version, and more. 

 

Click Project > Property to open Project Property window. Click Communication node to view 

the communication properties of the current module and controller. 

 

Figure 9-1 Communication properties 
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Section 10 Revision History 

Table 10-1 Revision history 

Version Applicable product model Remarks 

V1.0 (20230318) OMC High-performanceHMI V4.70.00.00 First release. 

V1.1 (20230830) 
OMC High-performanceHMI 
V5.10.00.00-M 

Updated screenshots. 
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